Rails bundle命令安装mysql gem包出错的解决方法

Tags: ruby

解决 Rails bundle 安装不上 mysql gem包的问题

环境

ubuntu 12.04
ruby-2.1.1

首先 新建一个的一个项目,在该项目上执行 bundle install

提示


...
Make sure that
gem install mysql2 -v '0.3.16'; succeeds before bundling
....

感觉非常奇怪

最后console提示


持续的困惑中,最后打开 mkmf.log 中,查看到 提示信息

cannot find -lmysqlclient

看到了希望,只要有错,就有希望,于是使用伟大的google 查找 cannot find -lmysqlclient

胜利的希望点这里

看了这篇,找到了感觉,最后在 /usr/lib 下,确实没有找到

libmysqlclient

按照提示


sudo apt-get install libmysqlclient-dev

安装成功之后,重新 bundle install 最后提示成功,WoW

做程序,就要有坚持和耐心!相信自己!

本文链接:http://www.4byte.cn/learning/1345.html



相关文章